summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoronly_vip <onlyme_vip@protonmail.com>2021-10-21 11:51:26 +0530
committeronly_vip <onlyme_vip@protonmail.com>2021-10-21 11:51:26 +0530
commite9b39e1e026533cd0b7d6b747afb82a6a5ad0bdc (patch)
treebba5ffe137d6fe828323a19756b34ab7033b9ece
parentba62df56a2e67b444ceb48c588266aa1630c3313 (diff)
downloadaur-e9b39e1e026533cd0b7d6b747afb82a6a5ad0bdc.tar.gz
libxft-dev and libxft2-dev dependency fix.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d4f342..4ed5e92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,13 +8,12 @@ pkgbase = rxvt-unicode-256color-unicode3
arch = x86_64
license = GPL
makedepends = libxft-dev
- makedepends = libxft2-dev
makedepends = perl
makedepends = libstartup-notification0-dev
makedepends = libstartup-notification0
makedepends = libxmu-dev
makedepends = libperl-dev
- depends = libxft-dev
+ depends = libxft2
depends = perl
depends = libstartup-notification0
optdepends = libgtk3-perl: to use the urxvt-tabbed
@@ -23,17 +22,5 @@ pkgbase = rxvt-unicode-256color-unicode3
conflicts = rxvt-unicode-256color
source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.26.tar.bz2
sha256sums = 643116b9a25d29ad29f4890131796d42e6d2d21312282a613ef66c80c5b8c98b
- bullseye_depends = libxft-dev
- bullseye_depends = perl
- bullseye_depends = libstartup-notification0
- bullseye_depends = libnsl-dev
- bullseye_depends = libnsl2
- bullseye_depends = terminfo
- hirsute_depends = libxft-dev
- hirsute_depends = perl
- hirsute_depends = libstartup-notification0
- hirsute_depends = libnsl-dev
- hirsute_depends = libnsl2
- hirsute_depends = terminfo
pkgname = rxvt-unicode-256color-unicode3
diff --git a/PKGBUILD b/PKGBUILD
index a8ecaa3..c532bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc="Unicode enabled rxvt-clone terminal emulator (urxvt) with 256 color and
arch=('x86_64')
url="http://software.schmorp.de/pkg/rxvt-unicode.html"
license=('GPL')
-makedepends=('libxft-dev' 'libxft2-dev' 'perl' 'libstartup-notification0-dev' 'libstartup-notification0' 'libxmu-dev' 'libperl-dev')
-depends=('libxft-dev' 'perl' 'libstartup-notification0')
+makedepends=('libxft-dev' 'perl' 'libstartup-notification0-dev' 'libstartup-notification0' 'libxmu-dev' 'libperl-dev')
+depends=('libxft2' 'perl' 'libstartup-notification0')
bullseye_depends=(${depends[@]} 'libnsl-dev' 'libnsl2' 'terminfo')
hirsute_depends=(${depends[@]} 'libnsl-dev' 'libnsl2' 'terminfo')
optdepends=('libgtk3-perl: to use the urxvt-tabbed')