Package Details: foot-bin 1.9.2-1

Git Clone URL: https://mpr.hunterwittenborn.com/foot-bin.git (read-only, click to copy)
Package Base: foot-bin
Description: Wayland terminal emulator - fast, lightweight and minimalistic
Upstream URL: https://codeberg.org/dnkl/foot
Keywords: fast foot lightweight terminal wayland
Licenses: MIT
Conflicts: foot, foot-git
Provides: foot
Submitter: only_vip
Maintainer: only_vip
Last Packager: only_vip
Votes: 2
Popularity: 0.88
First Submitted: 2021-10-04 15:31
Last Updated: 2021-10-06 08:11

Dependencies (17)

  • libxkbcommon-dev
  • libwayland-dev
  • libpixman-1-dev
  • fontconfig
  • libutf8proc-dev
  • meson (meson) (make)
  • ninja-build (make)
  • scdoc (make)
  • python3 (make)
  • libncurses-dev (make)
  • wayland-protocols (make)
  • libtllist-dev (libtllist-dev-bin) (make)
  • check (check)
  • libnotify (optional) – desktop notifications
  • xdg-utils (optional) – URI launching
  • bash-completion (optional) – bash completions for foot itself
  • foot-terminfo (optional)

Required by (0)

Sources (1)

Latest Comments

tapia commented on 2021-10-06 08:07

@only_vip I am using Ubuntu 20.04 (LTS). So that is why I have no libtllist-dev. I am planning to stay with the LTS versions at work, so I will have to wait until next year to have foot here :P

only_vip commented on 2021-10-06 07:34

@tapia, 1. regarding foot-terminfo, its available in bullseye. on ubuntu side its only available in hirsute and beyond. so i will include it as a opt-depends as of now and will eventually add a mpr package if i can. https://packages.debian.org/bullseye/foot-terminfo https://packages.ubuntu.com/search?suite=all&section=all&arch=any&keywords=foot-terminfo&searchon=names 2. regarding libtllist-dev, its available in bullseye, https://packages.debian.org/bullseye/libtllist-dev for ubuntu side, its in groovy and beyond. so which distro are you on exactly?

tapia commented on 2021-10-05 16:53

Hi, I have a problem when trying to build this package. Some of the dependencies cannot be satisfied:

==> ERROR: The following build dependencies were unable to be satisfied: foot-terminfo, libtllist-dev

This packages are not in the normal repos nor in the MPR. Are you planning to include them in the MPR, too?