Package Details: picom-git 1623.61.gee7d9612021.08.24-1

Git Clone URL: https://mpr.hunterwittenborn.com/picom-git.git (read-only, click to copy)
Package Base: picom-git
Description: X compositor (fork of compton) (git-version)
Upstream URL: https://github.com/yshui/picom
Keywords: compositor picom yshui
Licenses: MIT, MPL2
Conflicts: compton, picom
Provides: compton, picom
Submitter: only_vip
Maintainer: only_vip
Last Packager: only_vip
Votes: 1
Popularity: 0.042923
First Submitted: 2021-07-09 14:57
Last Updated: 2021-09-26 06:53

Dependencies (38)

  • libconfig-dev
  • libdbus-1-dev
  • libev-dev
  • libev-libevent-dev
  • libev-perl
  • libevdev-dev
  • libevent-perl
  • libgl1-mesa-dev
  • libpcre++-dev
  • libpcre2-32-0
  • libpcre2-dev
  • libpcre3-dev
  • libpixman-1-dev
  • libx11-xcb-dev
  • libxcb-composite0-dev
  • libxcb-damage0-dev
  • libxcb-glx0-dev
  • libxcb-image0-dev
  • libxcb-present-dev
  • libxcb-randr0-dev
  • libxcb-render-util0-dev
  • libxcb-render0-dev
  • libxcb-shape0-dev
  • libxcb-xfixes0-dev
  • libxcb-xinerama0-dev
  • libxcb1-dev
  • libxext-dev
  • uthash-dev
  • asciidoc (make)
  • cmake (make)
  • docbook-xml (make)
  • docbook2x (make)
  • git (make)
  • meson (meson) (make)
  • dbus (optional) – To control picom via D-Bus
  • python (optional) – For picom-convgen.py
  • xorg-xprop (optional) – For picom-trans
  • xorg-xwininfo (optional) – For picom-trans

Required by (0)

Sources (1)

Latest Comments

only_vip commented on 2021-08-06 16:35

done

hwittenborn commented on 2021-08-06 10:15

Hi,

Just testing some packages, and it looks like the libverto-libev1 dependency should be libverto-libevent1 (appears to be the dependency name on Ubuntu 20.04).

If the dependency name differs on Buster, could you just move libverto-libev1 to a buster_depends array?

only_vip commented on 2021-07-12 03:50

yeah i will check it with you change accordingly. any other dependecies that are changed in focal and beyond? i mainly tested for buster i guess i should change the depends function to buster_depends for better understanding.

hwittenborn commented on 2021-07-11 14:17

Hi!

I was just doing some testing, and it looks like the libpcre2-posix0 dependency is only applicable to Ubuntu 18.04.

If you scroll to the bottom of this page, you can see that the package name is libpcre2-posix2 in Ubuntu 20.04 and newer.

Could you get your PKGBUILD updated to reflect that?