Package Details: polybar 3.5.7-2

Git Clone URL: https://mpr.hunterwittenborn.com/polybar.git (read-only, click to copy)
Package Base: polybar
Description: A fast and easy-to-use status bar
Upstream URL: https://github.com/polybar/polybar
Licenses: MIT
Conflicts: polybar
Provides: polybar
Submitter: Tux
Maintainer: only_vip
Last Packager: only_vip
Votes: 1
Popularity: 0.42
First Submitted: 2021-08-14 21:12
Last Updated: 2021-10-09 07:46

Dependencies (52)

  • libasound2
  • libatomic1
  • libc6
  • libcairo2
  • libcurl4
  • libfontconfig1
  • libfreetype6
  • libgcc-s1
  • libmpdclient2
  • libnl-3-200
  • libpulse0
  • libstdc++6
  • libxcb-composite0
  • libxcb-cursor0
  • libxcb-ewmh2
  • libxcb-icccm4
  • libxcb-image0
  • libxcb-randr0-dev
  • libxcb-xkb1
  • libxcb-xrm0
  • libxcb1
  • cmake (make)
  • cmake-data (make)
  • libcairo2-dev (make)
  • libxcb1-dev (make)
  • libxcb-ewmh-dev (make)
  • libxcb-icccm4-dev (make)
  • libxcb-image0-dev (make)
  • libxcb-util0-dev (make)
  • libxcb-xkb-dev (make)
  • pkg-config (make)
  • python3-xcbgen (make)
  • xcb-proto (make)
  • libxcb-xrm-dev (make)
  • i3-wm (i3-gaps-git) (make)
  • libasound2-dev (make)
  • libmpdclient-dev (make)
  • libiw-dev (make)
  • libcurl4-openssl-dev (make)
  • libpulse-dev (make)
  • libjsoncpp-dev (make)
  • python3-sphinx (make)
  • python3-packaging (make)
  • libxcb-composite0-dev (make)
  • asciidoc (make)
  • docbook (make)
  • docbook2x (make)
  • ttf-unifont (optional)
  • i3-gaps-git (optional)
  • siji-git (optional)

Required by (0)

Sources (1)

Latest Comments

only_vip commented on 2021-09-16 07:30

https://ezup.dev/p/l2grou an edited pkgbuild which might solve the problems currently seen in the polybar

only_vip commented on 2021-09-16 06:54

https://packages.ubuntu.com/search?suite=all&searchon=names&keywords=xcbgen the current dependency of python-xcbgen is only for bionic. for focal and beyond the dependecy name is python3-xcbgen.

check line 30,66,67,68,90. https://ezup.dev/p/2caplo the documentation and the fonts are not installed. add the required dependencies to fix the issue.