makedeb


firewarden 1.1.5-0


Open a file via the specified application within a private Firejail sandbox.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for firewarden.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: Pig Monkey (AUR) <pm@pig-monkey.com>

pkgname=firewarden
pkgver=1.1.5
pkgrel=0
pkgdesc="Open a file via the specified application within a private Firejail sandbox."
arch=("all")
depends=("firejail>=0.9.56")
license=("UNLICENSE")
url="https://github.com/pigmonkey/${pkgname}"
source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
b2sums=('aa55759a8faff672239ff5222e49c388a46d087f2087514c19d66430eb4130b362c332a75965e8e56edd1ed1c535482d2deaf1061e4362fced5166fdb921e363')

package() {
  cd "$pkgname-$pkgver"
  # script
  install -Dm755 firewarden "${pkgdir}/usr/bin/firewarden"
  # docs
  install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname}/readme"
  install -Dm644 UNLICENSE "$pkgdir/usr/share/doc/${pkgname}/unlicense"
  install -Dm644 CHANGELOG.md "$pkgdir/usr/share/doc/${pkgname}/changelog"
  gzip "$pkgdir/usr/share/doc/${pkgname}/changelog"
}