makedeb


pingo 1.00a20-1


Lossless and lossy image optimizer for PNG/JPEG/WebP/APNG (uses wine)

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for pingo.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>
# Contributor: zocker_160 <zocker1600 at posteo dot net>

pkgname='pingo'
pkgver='1.00a20'
pkgrel='1'
pkgdesc='Lossless and lossy image optimizer for PNG/JPEG/WebP/APNG (uses wine)'
arch=('x86_64')
url='https://css-ig.net/pingo'
license=('unknown')
depends=('wine')
source=("${pkgname}-${pkgver}.zip"::'https://css-ig.net/bin/pingo-win64.zip'
        'pingo.sh')
sha256sums=('afec359d299007a854ceedd07a7cec0783fd937c4e16e1ae292b69cc7c7ab79d'
            '089b57d77443a41e576f16eb1f577d604aef24613b9b33dad183df728fa41e3f')

_useragent="User-Agent: Mozilla/5.0 (X11; Linux ${CARCH}) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.61 Safari/537.36"

DLAGENTS=("https::/usr/bin/curl \
              -gqb '' -LC - --retry 3 --retry-delay 3 \
              -H Upgrade-Insecure-Requests:\ 1 \
              -H ${_useragent// /\ } \
              -H Referer:\ https://www.css-ig.net/pingo \
              --compressed \
              --output %o \
              %u")

#prepare() {
    # nothing to see here
#}

package() {
    cd ${srcdir}

    install -D -m755 pingo.sh ${pkgdir}/usr/bin/${pkgname}
    install -D -m644 pingo.exe -t ${pkgdir}/opt/${pkgname}
}