makedeb


surgescript 0.6.0-0


SurgeScript is a scripting language for games.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for surgescript.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: José Rebelo (AUR) <joserebelo at outlook dot com>

pkgname=surgescript
pkgver=0.6.0
pkgrel=0
pkgdesc='SurgeScript is a scripting language for games.'
arch=('i386' 'amd64' 'arm' 'armel' 'armhf' 'arm64')
url='https://github.com/alemart/surgescript'
license=('Apache-2.0')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/alemart/surgescript/archive/v$pkgver.tar.gz")
b2sums=('5f8010be28e156df9f322d8c9eb3a8a3e8ef1e2a37d0942907e01f8b5e6b2ae1ef11140d6e2b0e8c8e067478f1bb52c947e8ee89e096ef06f674c14debe80d66')

build() {
  cd $pkgname-$pkgver
  mkdir -p build && cd build
  cmake -DCMAKE_INSTALL_PREFIX=/usr ..
  make -j $(nproc)
}

package() {
  cd $pkgname-$pkgver/build
  make DESTDIR="$pkgdir/" install
  cd ..

  install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/readme"
  install -Dm644 "CHANGES.md" "$pkgdir/usr/share/doc/$pkgname/changelog"
  ln -s /usr/share/common-licenses/Apache-2.0 "$pkgdir/usr/share/doc/$pkgname/"

  gzip "$pkgdir/usr/share/doc/$pkgname/changelog"
}