makedeb


violated-heroine-en 210112-1


Hentai 2D action RPG game. English Ver.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for violated-heroine-en.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>

_pkgname=violated-heroine
pkgname="${_pkgname}-en"
pkgver=210112
pkgrel=1
pkgdesc="Hentai 2D action RPG game. English Ver."
url='https://jbbs.shitaraba.net/otaku/14912/'
arch=('all')
license=('freeware')
makedepends=('gofile-downloader' '7z')
# rpg2003-rtp
depends=('easyrpg-player')
optdepends=('easyrpg-repo')
source=("${pkgname}.desktop"
        "${pkgname}.png"
        "${pkgname}.sh")
b2sums=('eac0ffc89b151931b27f123e186bd48ea9b2c3a3178041d59accb51a56e6ab887a82b145425a23bbfd723c67cb9a10e6f5592944c5ec5138ad4dcc0ca0ed9954'
        '461e3b5168c33c0db4267ee6bb554ddacf15f247f90a9f1715287944c8a3efa8bd085f8c5019fe3a81b0627af76df82625102dbe3af72ce9422a7219a7f2c378'
        '4495e0be44a5aee2e7b4aa5693ab42ed498103df8265fbc2d5bf02945c096f0b7de95a305545c7b5874888e12ff09f7dc44502e2fe17e67d5d89e22574746d78')
options=('!strip')

prepare() {
  # Process the assets, bug because of the download folder
  # https://www.reddit.com/r/ViolatedHeroineRPG/comments/14f4n7s/faq_for_the_game/
  _link='https://gofile.io/d/iAAKBB'
  _file='iAAKBB/VH_210112_V1_ENG.7z'
  _password="nanako"
  _b2sum='d9a9aa061994c7cb55c950ee232fc05410e0404e4806a816d3d88015d2ef7fa89dc1ac9aabd158729d196fe6565ec2413447080f5905242c1935ecc06fab513a'

  cd "${startdir}"
  # Download
  gofile-downloader "${_link}"
  # Checksum
  echo "${_b2sum} ${_file}" | b2sum --check
  # Clean
  rm -Rf "${srcdir}/${pkgname}-${pkgver}"
  # Extract
  7z x "${_file}" -o"${srcdir}/${pkgname}-${pkgver}" -p"${_password}"

  cd "${srcdir}/${pkgname}-${pkgver}"
  # Some clean up
  rm *.exe */*.exe *.dll *.DLL *.reg *.lsd *.bak .gitignore
}
         
package() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  # Folders
  install -dm755 "${pkgdir}/usr/"{games,share/{applications,games,icons/hicolor/96x96/apps}}
  # Script
  install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/games/${pkgname}"
  # Install data
  cp -R "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/usr/share/games/${pkgname}"
  # bug: fix permissions, can't chmod the extracted files directly. 
  chmod -R u=rw,go=r,a+X "${pkgdir}/usr/share/games"
  # Icon and desktop file
  install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
  install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/96x96/apps/${pkgname}.png"
}